Oracle ERP Financials – R12
Training Manual
Navigation

By: Salaih Muhammad (ACA)
APA, MSc Statistics, MSc Economics,
MA Arabic, MA Islamic Studies
Oracle Certified Professional (OCP)
Oracle Certified Expert (OCE)
+92-300-4428421
# TABLE OF CONTENTS

## INTRODUCTION

1.1 Logging in to Oracle Applications ................................................................. 3
1.2 Navigating from Personal Home Page to Applications.................................................. 4
1.3 Choosing a Responsibility...................................................................................... 6
1.4 Navigator ............................................................................................................... 7
    1.4.1 Expanding or Collapsing the Navigation List ................................................. 9
    1.4.2 Expanding or Collapsing Several Items ...................................................... 10
    1.4.3 Logging Out of Oracle Applications ............................................................. 11
1.5 Using Forms and Menus ......................................................................................... 12
    1.5.1 Navigating to a Form ..................................................................................... 13
    1.5.2 Form Terminology ....................................................................................... 14
    1.5.3 Creating and Saving a New Record ............................................................... 17
    1.5.4 Editing and Deleting a Record ...................................................................... 18
    1.5.5 Using a List of Values .................................................................................. 19
    1.5.6 Clearing Data .............................................................................................. 21
    1.5.7 Copying Data from a Record ........................................................................ 22
1.6 Query versus Find ............................................................................................... 24
    1.6.1 Using Find Mode ......................................................................................... 26
    1.6.2 Using Query Mode ...................................................................................... 28
    1.6.3 Query Operators ......................................................................................... 30
1 Introduction

1.1 Logging In to Oracle Applications

The first step in starting Oracle Applications is to enter the appropriate URL for your site in an Oracle Applications certified browser. After starting Oracle Applications, the first window you see is the login window. You need an Oracle Applications username and password to log in to Oracle Applications. It is different from the username and password you use to log in to your computer. If you are not sure of your Oracle Applications username and password, consult your system administrator. Oracle Applications security is based on your Oracle Applications username. Your username connects you to your responsibilities, which control your access to applications, functions, reports, and data.
1.2 Navigating from Personal Home Page to Applications

Navigating from Personal Home Page to Applications

Forms-based applications

Self-Service Applications

After you log in to Oracle Applications, your E-Business Suite Home page is displayed. From here you can:

- Access E-Business Suite Applications (professional or self-service)
- View and respond to notifications
- Set personal user preferences
- Navigate to other frequently used functions or Web pages

Note: The exact appearance of your windows may vary depending on which interface you are using and how it is customized at your site.

Two Types of Interfaces

Oracle E-Business Suite applications are either Forms-based or HTML-based. Forms-based applications are optimized for processing a large volume of transactions. HTML-based applications, sometimes referred to as “Self-Service Applications,” are optimized for ease of first-time use. For example, to enter a batch of journals, E-Business Suite provides a Forms-
based application. To submit an expense report, E-Business Suite provides an HTML-based application.
1.3 Choosing a Responsibility

Choosing a Responsibility

Each user has at least one responsibility and several users can share the same responsibility. Your system administrator can assign you any of the standard responsibilities or create custom responsibilities as per the business requirements. Each responsibility would be associated with a single Application, such as HRMS, General Ledger, and so on. You can access either Professional Applications or Self-Service Applications, but not both, based on the responsibility you are associated with. Click the underlined link in the Application section to select your responsibility and then click the underlined link to open a specific function.

*Note:* The exact appearance of your window may vary depending on which interface you are using and how it is customized at your site.
1.4 Navigator

The Navigator window displays the name of the responsibility you select in the title bar. Use this window to navigate to a form, so you can perform a specific business flow. You can navigate to the forms that are displayed in a navigation list on the left of the Navigator window. You can click the tabs to access the different regions.

**Navigator Region Tabs**

The Functions tab displays all of the applications functions that you can access for the responsibility that you selected. If you have a document, such as a particular purchase order, invoice, or sales order that you want to access later, you can create a link to the document using the Navigator’s Document feature.

The Navigator’s Document feature allows you to create as many links as you want and save them in the Documents region of the Navigator window. When you use a link to open a document, Oracle Applications opens the document in the appropriate form window. You can access the Document region using the tab control.
The Processes region of the Navigator (the “Process Navigator”) automates business flows across Oracle Applications forms. It allows you to model and execute complex business processes through an easy-to-use, graphical user interface. The business processes enabled through the Process Navigator can cross product boundaries and include complete business cycles.

The Process Navigator guides you step-by-step through each required function in a business process. In addition to providing a visual map of a business process, the Process Navigator can launch the appropriate Oracle Applications forms or standard reports at each step.
1.4.1 Expanding or Collapsing the Navigation List

Expanding or Collapsing the Navigation List

- Select one of the following methods to expand an item to its next sublevel window:
  - Double-click the item.
  - Select the item and click Open.
  - Select the item and click Expand.

- To collapse an expanded item, select the item and click Collapse.

Each user can access the Oracle Applications forms in several ways so that they can use the system quickly, according to their own computer style. Use the various buttons on the Navigator to manipulate list items.
1.4.2 Expanding or Collapsing Several Items

Expanding or Collapsing Several Items

To expand or collapse several items at once, click one of the following buttons:

- Expand All Children expands all the sublevels of the currently selected item.
- Expand All expands all the sublevels of all expandable items in the navigation list.
- Collapse All collapses all currently expanded items in the navigation list.

Each user can access the Oracle Applications forms in several ways so that they can use the system quickly, according to their own computer style. Use the various buttons on the Navigator to manipulate list items.
1.4.3 Logging Out of Oracle Applications

Logging Out of Oracle Applications

- From the File menu, select Exit Oracle Applications.
- Use this method to ensure that your username is cleared from system access.

![Oracle Applications Interface]

It is important to exit the system in this manner to ensure that your username is cleared from system access.

You can also close the multiple-document interface (MDI) window or use the [F4] function key.

Log out of Personal Home Page completely by clicking the Logout link.
1.5 Using Forms and Menus

Using Forms and Menus
1.5.1 Navigating to a Form

Use the Navigator window to navigate to a form that allows you to perform a specific business activity. The Navigator window is always present during your session of Oracle Applications and displays the name of your current responsibility in its title bar.
1.5.2 Form Terminology

Oracle Applications Release 12 works specifically in a Web-enabled environment. It is important to understand the terminology of the components within an Oracle Applications form. Common terms used in Oracle Applications forms are listed below:

- **Menu Bar**: Use pull-down menus from this menu bar to navigate or perform actions within a form.
- **Window**: It is an area where the user interacts with an application. (Many windows can be open at one time and you can access these “overlapping” windows to perform data entry or data search activities.)
- **Window title**: It is the text in the title bar that indicates the name of the window and usually gives context information pertinent to the information in that window.
- **MDI window**: It is a master container window that houses all windows, toolbars, and application windows.
- **Tool tip**: It is an iconic bubble help that you can use to determine the function of a button on the toolbar.
- **Record or row**: It is a set of one or more related data items from a table or view that are grouped for processing.
- **Check box**: It is a box in which you can toggle between an “on/off” or “yes/no” state for a particular value.
- **LOV icon**: It is an icon that you can click to display a list of values (LOV) for the current field.
- **Pop-up list**: A pop-up list lets you select a single value from a short list.
- **Scrolling region**: It is a region containing a scroll bar, in which to view other fields.
- **Block**: It is an area of information relative to a specific business function or entity.
Form Terminology (continued)

- **Region**: It is a logical grouping of fields set apart from other fields by an outline.
- **Region tab**: It is a collection of regions that occupy the same space in a window, where only one region can be displayed at a time.
- **Field**: It is an area in a window that displays data or enables you to enter data.
- **Button**: It is a graphic element that initiates a predefined action when you click it.
1.5.3 Creating and Saving a New Record

Creating and Saving a New Record

New       Save

(M) File > New       (M) File > Save

To Create a Record

Choose New from the File menu or use the New toolbar icon. After entering data for your new record, select Save or Save and Proceed from the File menu to save the record to the database. Choosing Save and Proceed automatically advances you to the next record.
### 1.5.4 Editing and Deleting a Record

**Editing and Deleting a Record**

<table>
<thead>
<tr>
<th>Edit</th>
<th>Delete</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Edit Icon]</td>
<td>![Delete Icon]</td>
</tr>
</tbody>
</table>

**To Edit a Record**

Choose Record from the Edit menu. This action allows any change to be made to the selected record from your editable screen.

**Note:** Fields protected against any updated cannot be edited.

**To Delete a Record**

Choose Delete from the Edit menu. This action erases the current record from your screen and returns your cursor to the first field of the next record.

**To Save Your Deletion from the Database**

Choose Save or Save and Proceed from the File menu.

**Note:** All records cannot be deleted in this manner. Those records which cannot be deleted need to be end dated and such end-dated records cannot be used further.
1.5.5 Using a List of Values

A field that has a predefined list of valid values displays an LOV icon. Select this icon to view the valid field values. If a list contains more than 100 values, you are prompted to enter a Find string to limit the list.

**Note:** Lists that require a Find string do not use the auto reduce feature.

**To Select a Value from a List**

Select a value or reduce the list using one of the following methods:

Without placing your cursor over the Find field, enter the initial characters of a value to auto reduce the list to those items matching the characters entered. Press [Backspace] to re expand the list. If your entry reduces the list to a single value, the list window closes and inserts the value into the field. In the list window, enter any group of characters in the Find field and select the Find button.
Note: Use the wildcard character (%) to represent any number of characters and the underscore (_) to represent a single character. Do not enter a wildcard character by itself. This will match all records.
1.5.6 Clearing Data

You can clear data from the screen at almost any time.

Typically, you will use this feature when you start to enter data in a field and then change your mind.

Oracle Applications will think you are in the middle of processing a record and will not allow you to proceed with the next task until you clear the field.

The data you clear is simply erased from the screen and not deleted from the database.

Note: If the data is new and has never been saved to the database, it will be lost permanently when you clear it from the screen.

(M) Edit > Clear and then select the appropriate option, to clear a field, record, block, or form.

You can also clear some or all data from a field by highlighting the data and selecting (M) Edit > Cut.
To save time during data entry, you can duplicate data from a previous record if much of the data needs to be repeated again in the new record. You can use Cut, Copy, and Paste from the Edit menu or you can use the following techniques:

**Copying a Field Value from the Previous Record**

1. Enter a new record or query an existing record in your form.

2. (M) File > New or click the New icon to insert a new record after the existing record.

3. Place your cursor in the field whose value you want to duplicate.

4. (M) Edit > Duplicate Field Above, to copy the field value from the previous record into the current record.
Copying All Field Values from the Previous Record

1. Follow steps 1 and 2 mentioned above.

2. (M) Edit > Duplicate Record Above, to copy all field values from the previous record into the current record.

Note: Depending on the record storage in the database and relevant database tables, not all fields may be copied when using this feature.
## 1.6 Query versus Find

### Query Versus Find

<table>
<thead>
<tr>
<th>Query mode</th>
<th>Find mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu bar, [F11]</td>
<td>Menu bar, Toolbar</td>
</tr>
<tr>
<td>Existing window</td>
<td>Find window</td>
</tr>
<tr>
<td>Wildcards</td>
<td>List of values</td>
</tr>
<tr>
<td>Query count</td>
<td>No find count</td>
</tr>
</tbody>
</table>

### Query Mode

- In Query mode, you can use the menu bar to access a query, or you can use keyboard shortcuts [F11] to enter a query and press and hold [Ctrl] + [F11] to execute a query.
- You use the existing window to prepare your search criteria for the query. You can enter specific information in any field to narrow your search.
- When using wildcards to prepare your search criteria, you can use all query operators to narrow your search.
- In query mode, you can check to see how many records match your criteria even before retrieving the data that matches your query.
Find Mode

- In Find mode, you use the menu bar to access the Find window, or you click the icon on the toolbar.
- You use a new window, the Find window, to prepare your search criteria.
- The list of values is available in many fields in Find mode.
- The Query Count feature is not available in Find mode.
1.6.1 Using Find Mode

Using Find Mode

Click the Find icon on the toolbar:
- Click the Find button on the Form.
- Specify your search criteria.
- Review the retrieved records.

To search for records in your current block or window, use the Find window. The Find window contains fields for entering search criteria. These fields are specific to the current block and often validate the search criteria you enter against a list of valid values.

Generally, a Find window is displayed for those blocks that have many records or for those blocks that can be best searched using criteria in more than one field.

How to Use Find Mode

(M) View > Find or click the Find icon on the toolbar.
- Enter your search criteria in the appropriate fields of the Find window.
- If a field does not provide a list of values for you to choose from, you can enter wildcard characters (\% and -) in the search phrase. You cannot, however, use query operators (such as >, <, and so on) in a Find window.
- Click the Find button to find any matching records.
· Click the Clear button to clear the current search criteria from the Find window, so you can enter new search criteria.
· Click the New button to enter a new record in your current block if your search finds no matching records. Not all windows support the Find.
1.6.2 Using Query Mode

Using Query Mode

(M) View > Query By Example > Enter:
• Enter the search criteria.
• (M) View > Query By Example > Run.
• (M) View > Query By Example > Cancel.

How to Use Query Mode

1. (M) View > Query By Example > Enter.

2. Enter the search criteria in any of the fields (indicated by blue) that can be queried, using wildcard characters and query operators as necessary. You can also select View > Query By Example > Show Last Criteria to display the search criteria used in your last search, if you performed one.

3. (M) View > Query By Example > Run to perform the search.

4. (M) View > Query By Example > Cancel to cancel from Enter Query mode.

How to Obtain a Query Count
1. Perform steps 1 and 2 above.

2. (M) View > Query By Example > Count Matching Records to display the number of records a Query By Example search would retrieve.
1.6.3 Query Operators

You can use any of the query operators listed in the table shown in the slide. You can also use the percentage (%) wildcard character to represent any character or group of characters. For example, use “Manuf%” to represent Manufacturing, Manufacturer, and so on. You can also use the underscore (_) character to represent any single character. For example, “Product_” can represent ProductA or Product1.